Some Google Calendar users are not able to book meetings due to disconnected calendar
Incident Report for Chili Piper
Resolved
After continuous monitoring, we are confirming this incident is resolved. Our team will continue to monitor the status of Google connections across our infrastructure to ensure stability is maintained.

Users who were impacted by the initial incident may find that their calendars are still disconnected. The resolution of this incident does not retroactively restore connections. If you have a user that is disconnected, please ensure they reconnect by logging into Chili Piper with their Google credentials.
Posted Apr 15, 2022 - 22:36 UTC
Monitoring
We are working to implement fixes for the identified issues and are monitoring the results. Most users should have at least attempted to reconnect their Calendar and we have noticed a significant drop in error rates.

Please continue to reconnect your calendars and the calendars of assignees / bookers if trailing reports come in. Once reconnected, the issues should be fully mitigated for those users.

If you are experiencing critical issues as a result of the incident, or experiencing difficulty reconnecting, please reach out to our Department of Customer Love support team at support@chilipiper.com or your dedicated Customer Success Manager so that we can investigate.
Posted Apr 15, 2022 - 13:00 UTC
Update
Our engineering team is working to get the identified issues resolved as quickly as possible, and progress is being made. We urge customers who are impacted to continue to attempt to reconnect their Calendar if they are experiencing unexpected behaviors while using Chili Piper, even if the UI indicates you are fully connected.

Login with Google credentials: https://apps.chilipiper.com/login.html?success=true to attempt to reconnect.

We have learned that multiple attempts may be required in order for the new credentials to take hold.

The impacting issues include, but are not limited to, calendars showing no availability or not loading at all, Instant Booker showing issues sharing or viewing calendars, and issues where the Booker of the meeting receives the event (as organizer) rather than the Assignee.
Posted Apr 14, 2022 - 20:56 UTC
Identified
We have identified some of the underlying root causes of Google calendars disconnects and are continuing to investigate a resolution.

It is still recommended that impacted users reconnect their calendars as this resolves the problem in most cases. This can be done by simply logging into Chili Piper and using your Google calendar as the login option here:
https://apps.chilipiper.com/login.html?success=true

We will continue to provide the latest updates here as they become available.
Posted Apr 13, 2022 - 22:37 UTC
Update
We are continuing to investigate the issue and are narrowing down the root cause.

Impact:
- You may see issues displaying the proper availability on booking links or within Instant Booker.
- If you are the "Default Booker" within a Concierge queue, you may get more meetings booked to your calendar.
- Updates to Google events such as reschedules or cancellations may not happen automatically.

As noted previously, reconnecting Google on a user-level renews disconnection and permanently fixes the issue. If you are impacted, check out our help article for the steps to reconnect:

https://help.chilipiper.com/hc/en-us/articles/360053800193

Please stay tuned here for updates.
Posted Apr 11, 2022 - 19:11 UTC
Update
Our engineering team is still investigating the Gcal token disconnects - the issue seems to be related to Google API's permissions scopes.

Reconnecting Google on an individual level renews the token and permanently fixes the issue. If you are impacted, check out our help article for the steps to reconnect:

https://help.chilipiper.com/hc/en-us/articles/360053800193

We'll update this incident with more details.
Posted Apr 11, 2022 - 15:57 UTC
Investigating
We are currently investigating an issue with some Google Calendar users not able to book meetings due to Gcal being disconnected. Only a minority of Gcal customers are experiencing this issue, O365 customers are not affected.

If booking via Instant Booker, the booker will see the message "You can't book meetings in this calendar'.

If booking via a personal or queue link, the prospect will see the message "Select a different slot"

To fix this immediately, please change the default booker to a different user with a valid calendar connection, or have the default booker reconnect their calendar under https://apps.chilipiper.com/meetings/personal-settings/integrations

Check out this help article for detailed steps: https://help.chilipiper.com/hc/en-us/articles/360053800193

We'll keep you updated via this thread.
Posted Apr 11, 2022 - 14:40 UTC
This incident affected: Booking - expand for components (Instant Booker, Booking Links) and Google Calendar.