The retroactive update has been completed, and all accounts should properly be in a connected status at this time.
We do have a retry mechanism that will automatically re-attempt CRM Actions in Salesforce if they had been previously unsuccessful in most cases.
Posted Apr 08, 2026 - 20:38 UTC
Identified
We have deployed a fix for the Salesforce connectivity issues. We will also apply a retroactive update to proactively reestablish the Salesforce connection for affected tenants. The ETA for completion is approximately 30 minutes.
In the meantime, if you see your Salesforce connection status currently set to "In Trouble," you can also have the integration user reconnect to Salesforce in the admin center, which will resolve the problem immediately.
Posted Apr 08, 2026 - 20:01 UTC
Investigating
We see some customers have connectivity issues with Salesforce CRM. In the app, it will display "In Trouble" status when it is not connected.
All CRM functionality, such as Contact/Account routing, email lookups, and rules logic may not work correctly while this is the status.
We are internally working to reestablish the connection for affected customers, but in the meantime, if you see "In Trouble" or "Disconnected" status in the Admin Center's Integrations page, please try reconnecting to Salesforce from the appropriate integration user's Salesforce account, which should restore the connection.