HubSpot CRM API rate limit impacting connection to CRM
Incident Report for Chili Piper
Resolved
This incident has been resolved. We are continuing to monitor, but have seen a significantly steep decline in error rates that are now within normal limits.

For most customers, no further action is required.

If you notice issues with routing, 500 errors, or issues connecting to the CRM, please login as admin and reconnect the sync user at https://apps.na.chilipiper.com/admin-center/integrations. Doing so should put you back in business.
Posted May 27, 2022 - 21:54 UTC
Monitoring
We have deployed a few hotfixes and are monitoring the results now. Customer accounts appear to be recovering after a short wait. In the meantime we will continue to keep an eye on error rates to ensure they are dropping.

Once we have confirmed the resolution, we will provide another update.
Posted May 27, 2022 - 21:10 UTC
Identified
Please be aware that HubSpot CRM-connected customers may experience intermittent issues related to their connection.

The scope of this issue can cause problems routing via web form, logging in with HubSpot, setting queue rules, refreshing fields, or doing Contact update/search.

One primary symptom is hitting a "500 error" when attempting to submit a form or do admin tasks.

Our engineers have identified several root causes and are working to mitigate this. Additionally, we are refactoring the way these requests happen to ensure this does not impact connections in the future.

We will have more information on a resolution soon.
Posted May 27, 2022 - 20:00 UTC
This incident affected: Chili Piper (Concierge routing).