[Office 365 Customers] Reports of Calendar Events being Duplicated automatically
Incident Report for Chili Piper
Resolved
The Microsoft API has stopped returning errors and duplicating calendar events upon creation as of today. We have not received any additional reports as of this afternoon. If you find this issue persist for your team, please report to support@chilipiper.com.
Posted Nov 08, 2019 - 04:22 UTC
Investigating
We've received reports that users who use O365 as their Calendar are intermittently seeing Calendar Events being created 2x in their O365 Calendar. This appears to have started around Nov 1st, 2019 per an update MS pushed to their API. We've been able to recreate this on our side as well.

MS hasn't published anything on their status page on this unfortunately, but here's a link to report of a related error that we are seeing. https://stackoverflow.com/questions/58663396/getting-error-code-errorirresolvableconflict-responses-when-trying-to-create-e
In a reply on Nov 1st '19, a Sr Software Engineer at MS commented that they are working on the fix and should have it resolved in the next few days. That is the latest update we have found.

From our logs, it looks like Chili Piper is only creating 1 of the events as expected and what it looks like is that MS is somehow duplicating events randomly. We've received additional reports from other clients that this isn't just happening to Chili Piper created events, but to other O365 Calendar tools as well which implies this is likely something related to a MS update.

We will keep you posted as we learn more.

Removing 1 of the 2 events directly from the calendar may be a manual workaround, however be advised that the end users don't have an easy way to know which meeting was created by Chili Piper. In the event that the rep deletes the Chili Piper created event and not the MS created duplicate, the ability to reschedule or reassign that meeting will likely become unavailable and can potentially affect your Salesforce reporting on canceled meetings.
Posted Nov 06, 2019 - 15:49 UTC