Chili Piper loading slowly and timing out
Incident Report for Chili Piper
Resolved
We have restored all services and databases to fully operational status.

Our team will continue to monitor the results to make certain these services remain healthy and have provided additional resources to ensure stability moving forward.
Posted Jun 03, 2022 - 02:04 UTC
Update
Our team is making good progress in restoring the database services that are still impacted and this may take take an extended amount of time to complete.

While this is in progress you may experience issues with reporting, reminders, and some automated services, however booking flows and most admin functions should work normally. There will be no loss of data.

Stability of these services is extremely important to us and we are working to ensure this is more robust moving forward. We will provide another update once all services have been restored.
Posted Jun 02, 2022 - 20:16 UTC
Update
Impact has been minimized and we have a clear plan in place to get back to fully operational mode without any loss of data - we are executing on it right now. Once we're fully healthy we'll re-enable all less essential services such as reminders and we'll investigate what happened in detail.
Posted Jun 02, 2022 - 17:15 UTC
Update
Our engineers restored all database instances to a 'partial mode' - Chili Piper is now loading as expected and booking flows are back to normal, but reminders, reporting and some automated processes still need to be restored. We are working on restoring all functionality, we will update you once the process is finalized.
Posted Jun 02, 2022 - 16:42 UTC
Identified
Our Team has identified the issue as stemming from the primary database. We are working on a plan to restore functionality without losing any data. We will keep you update!
Posted Jun 02, 2022 - 16:20 UTC
Update
We are continuing to investigate the root cause with our Reliability Team. The issue manifests in not being able to log into the Dashboard or book meetings. We will keep you updated as new details emerge.
Posted Jun 02, 2022 - 16:10 UTC
Investigating
We are seeing instances of the Dashboard loading slowly and timing out with 502 errors. Our Engineering Team is investigating
Posted Jun 02, 2022 - 15:47 UTC
This incident affected: Booking - expand for components (Dashboard, Instant Booker, Booking Links) and Google Cloud Storage, Google Cloud DNS, Salesforce API, Google Calendar, Zoom Meetings, Salesforce USA1.