Degraded performance through Distro routing

Incident Report for Chili Piper

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 17:25 UTC

Monitoring

We have been alerted to potential delays while routing records through Distro. As a result, you may notice that Distro is not identifying and routing new records. Customers may also have identified these delays yesterday (12/4) between 11:30 AM and 3:00 PM UTC.

This delay was caused by an influx of triggered events that exceeded the maximum load possible. This caused the event processing time to grow exponentially for all customers. Services are expected to recover, identify, and route any delayed records soon, with no action needed on the Chili Piper Admin's side at the moment.

This is not impacting Concierge, Concierge routing, the booking / scheduling platform, or ChiliCal's extension.

We will keep monitoring the results and will soon provide more updates. If you have any questions, please email support@chilipiper.com
Posted Dec 05, 2025 - 13:27 UTC