Chrome Extension is non-operational
Incident Report for Chili Piper
Resolved
The newest version of the Chrome Extension was approved by the Chrome store and this is available to everyone (version 3.0.486):
https://chrome.google.com/webstore/detail/chili-piper-automate-sche/digckgagekofoajjlaeceojmdokllfmf

If you have uninstalled the extension, please just install it back and it will be with the proper version.

If you have only disabled it, please follow these steps:
1. Go to the extension settings at chrome://extensions/?id=digckgagekofoajjlaeceojmdokllfmf
2. At the top-right of the page, click on the toggle to enable the extension again;
3. At the top-left, click on the "Update" button.

As soon as you confirm that the extension is now active and have the v3.0.486 installed, you can remove the local copy of our extension previously installed:
1. Go to this page: chrome://extensions/?id=kdmalpdadhpjffdocncnecbpkcgkngge
2. At the end of the page, you can click on "Remove extension".

Thank you for your understanding and patience on this and we are sorry for any inconvenience this issue might have caused you.
Posted Jul 03, 2022 - 12:09 UTC
Update
We continue to wait on the Chrome store approval process to publish the changes we have made to the Chrome Extension. Though we have no ETA on this, we expect it should be any moment now.

For some additional information into next steps - We have since fixed the pipeline to ensure this is built correctly in the future and have additionally assigned resources to manually test these builds across all environments before release.

Any users who have installed the local copy of our extension will eventually need to remove it and install the public copy again. We will provide steps for this once the extension is fixed in the store, and this will not urgently need to happen immediately.

In the meantime, please continue to follow the steps listed in our knowledge base article for a temporary solution:
https://help.chilipiper.com/hc/en-us/articles/7406298455059
Posted Jul 01, 2022 - 16:21 UTC
Update
Per our previous update we are still waiting on the Chrome app review process. Unfortunately, this can take some time for Google to complete and although we don't have an exact ETA, it can take up to 24 hours to approve.

In the meantime, we have released a local download copy of our fix that can be deployed immediately. Steps are provided in our helpdesk article as well as a video highlighting the step-by-step process. We have confirmed that this local copy resolves the issue once installed.

To view these steps and download a local copy, review this page here: https://help.chilipiper.com/hc/en-us/articles/7406298455059

If you opt not to install the local copy the Chrome extension will eventually update automatically once approved on Google's end with no action needed on your end.

We will continue to monitor the fix and ensure we provide an update here once it has rolled out to the majority of customers via the Chrome web store.
Posted Jun 30, 2022 - 19:08 UTC
Monitoring
Our engineering team identified the cause of the issue and a fix was created. The new version was sent to Chrome Review, which can one day or more.

In the meantime, please follow the steps described in the following article to make the extension operational again:
https://help.chilipiper.com/hc/en-us/articles/7406298455059
Posted Jun 30, 2022 - 14:35 UTC
Investigating
The Chrome Extension is currently not working for customers with instances on the production cluster. The issue is not affecting instances running on the canary cluster.

Our engineering team is already analyzing the issue to provide a fix.
Posted Jun 30, 2022 - 13:55 UTC
This incident affected: Booking - expand for components (Chrome Extension).