Legacy links and redirects experiencing longer than expected load times

Incident Report for Chili Piper

Resolved

We've completed the necessary configuration changes and access to resources has been restored for impacted legacy customers.

A thorough review of this configuration and what occurred will be completed to ensure it remains stable.
Posted Dec 12, 2025 - 23:23 UTC

Identified

It appears the issue may stem from Cross-Origin Resource Sharing (CORS) adjustments that were made. As a result, the legacy Canary platform links are blocked from accessing various resources needed to properly load booking link pages.

Our team is working to restore access to these resources now.

This does not impact Fire platform or Fire services including Fire scheduling links, and it appears to be limited to a specific "Canary" environment within our legacy platform.
Posted Dec 12, 2025 - 22:58 UTC

Investigating

We are currently investigating reports of increased load times affecting legacy links and redirects. The impact we are seeing is on both links and web form snippets. This impacts both standard booking links (meeting types, queues), and Concierge router links.

Load times vary from 10-30 seconds on impacted calendar links. Once links load, it appears they do not natively redirect to Fire platform as they are supposed to.

As this is impacting only our legacy platform, a potential fix would be to fully migrate services and links to their redirected Fire platform counterparts as they are not impacted.

No Fire services appear to be impacted at this time.
Posted Dec 12, 2025 - 22:39 UTC
This incident affected: Booking - expand for components (Booking Links).