Email notification deliverability issues

Incident Report for Chili Piper

Resolved

We are now considering this issue resolved, as we're seeing better results. The issue lasted from 17:30 to 19:20 UTC and impacted email notifications such as meeting confirmations emails, record assignment emails, and Reminders for Chili Piper users.

The internal service responsible for such notifications had some configuration issues, which were already mitigated. Our teams are already working on lessons learned and how we can avoid this from happening in the future.

The issue has not affected the ability to book meetings across products, including our extension, assigning records via Distro, and prospects from receiving meeting invites and calendar event confirmations.

If you have any further questions, please reach out to support@chilipiper.com
Posted Dec 17, 2025 - 20:09 UTC

Investigating

We are currently investigating an issue that is preventing email notifications from being sent. This means Chili Piper users will likely not receive notifications, such as meeting confirmations and record assignments.

This is not impacting Concierge, Concierge routing, the booking/scheduling platform, or ChiliCal's extension. Also, prospects are expected to receive email notifications and calendar events, as the issue is isolated to Chili Piper users' notifications.

We will send more updates as soon as our investigation moves forward. If any questions, please reach out to support@chilipiper.com
Posted Dec 17, 2025 - 18:22 UTC