[Legacy app] Admin center unresponsive in Chrome v135

Incident Report for Chili Piper

Resolved

We identified a third-party script was causing the admin center page to hang. We have blocked this script, and pages now load as expected.

No further impact is expected as a result of blocking this script.
Posted Apr 09, 2025 - 00:58 UTC

Investigating

We have discovered that as of the latest update in Google Chrome version 135, the "Admin Center" in our legacy app (apps.chilipiper.com) becomes unresponsive due to memory usage.

You are still able to navigate around workspaces, and from workspace-to-workspace, but the browser will become unresponsive if you attempt to navigate back to the Admin Center.

Our engineers are investigating the cause right now as it relates to v135. Older versions of Chrome are confirmed not to be impacted. Other browsers or chrome-based browsers appear to be unaffected as well.

This does not impact our Demand Conversion Platform (Fire) app.
Posted Apr 08, 2025 - 18:27 UTC
This incident affected: Booking - expand for components (Dashboard).